Solucionar “Error en el servicio de perfil de usuario al iniciar sesión” en Windows Vista

Normalmente, casi todos los errores que salen en Windows Vista se pueden solucionar mediante:

  • un chkdsk /f/r (completo) puesto que el sistema, como si de una forma de masoquismo se tratara, se autolesiona él mismo.
  • un format c: /q (como los de antaño)

Seguro que hay más formas de solucionar los problemas pero en Windows si no es una de las anteriores se pierde el tiempo. Esta claro que estoy exagerando un poco, aunque creo que no estoy tan equivocado. En fin … A lo que vamos.

Puede ser que en Windows Vista, al iniciar el pc/portátil, no nos acceda al Escritorio (o cargue nuestro perfil de usuario) y no salga un mensaje que nos diga “Error en el servicio de perfil de usuario al iniciar sesión“. Según el Knowledgment Base de Microsoft, nos dice que se su causa es:

Este problema puede producirse si el perfil de usuario se elimina manualmente (¿?) mediante el uso de la línea de comandos o mediante el Explorador de Windows. Un perfil que se elimine manualmente no quita el identificador de seguridad (SID) de la lista de perfiles en el registro.

Si el SID (Security IDentifier) está presente, intentará cargar el perfil utilizando elProfileImagePathque señala a una ruta de acceso que no existe. Por lo tanto, no se puede cargar el perfil.

Es decir, por arte de magia nos hemos eliminado a nosotros mismos de los perfiles de usuario. ¿a qué mola? (¿entendéis lo que decía antes del masoquismo en Windows Vista?). La solución que dan es, como suele pasar en Windows, eliminar una clave del registro y reiniciar. Puede que así o nos cargamos aun más el sistema o por el contrario, se recupere el perfil de usuario de las backups. Pero existe otra solución, rápida, sencilla y sin (casi) ningún riesgo (en Windows no existe el factor “sin riesgo”) y como no, deberemos tocar (un poquito) el registro de Windows. Los procesos a seguir son los siguientes:

  • Reiniciamos y pulsamos F8 para cargar el menu de arranque de Windows
  • Arrancamos en Modo Seguro
  • Accederemos a Windows en modo Administrador
  • Haremos Inicio -> Ejecutar
  • Escribiremos regedit y le daremos al Ejecutar

Aquí dentro vigilad lo que tocáis puesto que nos podemos cargar el sistema operativo enterito. Deberemos buscar la siguiente clave en el registro, expandiendo las diferentes ramas del mismo:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\ProfileList

Expandimos un poco la ventana de la derecha y veremos dos perfiles de usuario con el mismo nombre (p.ej. 000000-111111-222-333-4444) y uno de ellos terminará en .bak. Lo que se trata es de invertir la clave, es decir, cambiar la extensión .bak de una por la otra. Os pongo un ejemplo:

Siguiendo las imágenes siguientes, vemos las dos claves de registro

Modificamos (pulsando F2) el nombre de una y cambiamos .bak por .bak2. Vamos a la que no tiene extensión y le ponemos una extensión .bak

Eliminamos la extensión .bak2 dejando la clave sin extensión

Una vez hecho esto, cerramos el regedit, reiniciamos y ya no nos saldrá más el error y podremos acceder sin ningún problema a nuestra sesión de Windows Vista. Cierto es que este error me salió hace ya tiempo y lo solucioné haciendo un chkdsk del disco duro. Otros compañeros me han comentado que a base de reiniciar varias veces, se ha solucionado el problema (¿?). Si os dejáis aconsejar, en cuanto podáis quitaros el Vista y instalaros Windows 7 o Ubuntu.

No le tengo manía a Windows ni mucho menos. De hecho, uso tanto Ubuntu como Windows 7 y por motivos de faena, casi siempre tengo que lidiar con Windows XP o Windows Vista y la verdad, éste último no me gusta en absoluto.

Espero que os haya servido. Un saludo.

22 Responses to “Solucionar “Error en el servicio de perfil de usuario al iniciar sesión” en Windows Vista”


  1. 1 Silvestre 10/21/2010 a las 1:44

    Gracias pana, lo acabo de solucionar en Win 7, osea el problema tambien aparece en esta version :-S.

  2. 2 Adriwan 10/21/2010 a las 8:26

    Que raro … en Windows 7 también? tomaré nota de ello pero es extranyo puesto que W7 está muy per encima de Windows vista. Gracias por tu comentario y gracias por leer controlshiftesc.wordpress.com:)

  3. 3 Rober 01/30/2011 a las 20:40

    Hola, a mí también me ha pasado en un Windows 7 Home Premium 32b recién instalado justamente después de actualizar.

    Gracias y un saludo.

  4. 4 Ricky 02/22/2011 a las 23:54

    Acabas de salvarme 200 Videoclips, los cuales utilizo para pinchar.
    Me pasó con Windows 7!! Muchas Gracias

  5. 5 Ismael 08/02/2012 a las 5:44

    Ami me pasa eso en win7 y no lo eh podido solucionar D:
    CUando busco eso del bak ninguno sale con bak
    QUE AGO D:
    YA ME ARTE y es la segunda ves que me pasa
    Y deduci que ese problema pasa con las estupidas actualizaciones automaticas del sistema
    Aveses pienso que windows lo hace aproposito para JODERME LA VIDA D:
    Ya que eh tenido muchas experiencias con la xp Eh jodido por completo mi computadora 7 veses D:
    Asi si alguien me pudiera decir como hacer para arreglarla😀

  6. 6 Ismael 10/18/2012 a las 12:05

    Buenas, me pasa lo mismo, sé solucionar el problema pero lo sorprendente es que me ha pasado en un Wi dows 7 Home Premium una sorpresa desagradable pero bueno. Saludos

    • 7 Marcelo 10/31/2012 a las 15:15

      ismael me paso lo mismo luego de una actualización de win 7, como lo solucionaste? cuando inicio en el area de notificación me aparece un candadito y en los sucesos de sistema este error, me podes dar una ayuda? Gracias!

  7. 8 Escor 11/29/2012 a las 1:47

    me pasa lo mismo, estoy dentro d eun dominio y quiero logearme con otro usuario y me manda ese error, pero busco en el registro y no me aparece ese archivo con .bak, tengo en mi folder de usuario el nuevo folder del perfil que quise poner pero no tien nada e igual tengo otro folder alli que dice temp. esta esto bien??? bueno logicamente no pero como lo solciono me urge ayuda

  8. 9 kiko 12/03/2012 a las 22:45

    llevo dos semanas renombrando los archivos del .bak de uno al otro, reincio y…sigue exactamente igual…no hay manera de cargar el usuario.

  9. 10 Jose 09/02/2013 a las 10:48

    He seguido tus consejos y me ha ido perfecto. Muchas gracias

  10. 11 Alex 09/02/2013 a las 19:04

    La solución funciono perfecta, ocurrió en Win7 Home Premium, muchas gracias.!!

  11. 12 Guillermo Boticelli 09/05/2013 a las 4:16

    No ma… Bájate la bragueta!! Todo ok!!

  12. 13 Miriam H. 09/29/2013 a las 21:17

    Funcionó perfecto, gracias!

  13. 14 Pas 09/30/2013 a las 19:43

    Muchas gracias colega. Tengo el w7 home premiun y funciona correctamente lo unico que me ha cambiado el fondo de escritorio
    y el google crome

  14. 15 Verito 10/05/2013 a las 1:11

    =) muchas gracias !!!!! me funciono muy bien !!

  15. 16 roberto 10/05/2013 a las 20:04

    Asu si funciono gracias ya lo arregle

  16. 17 Yamila Farinelli 10/17/2013 a las 20:08

    Hola tengo el mismo problema con windows 7 home premium, primera vez que me pasa, quiero seguir los pasos, pero no me toma el maldito F8, mi computadora es una PHILCO PHN14C1. Hay alguna otra cosa que pueda hacer? y mi perfil es el unico, nunca hice otra perfil de usuario como administrador.

  17. 18 Nico 10/20/2013 a las 14:14

    HOLA, TENGO WINDOWS7 LLEGO HASTA PROFILELIST PERO NO ME APARECE NINGUN REGISTRO IGUAL AL OTRO
    Nombre Tipo Datos
    (Predeterminado) REG_SZ (valor no establecido)
    Default REG-EXPAND_SZ %SystemDrive%Users/Default
    ProfilesDirectory REG-EXPAND_SZ %SystemDrive%Users
    ProgramData REG-EXPAND_SZ %SystemDrive%ProgramData
    Public REG-EXPAND_SZ %SystemDrive%Users%Public

    ESTO ES LO QUE ME APARECE EN LA NOTEBOOK WIN7 AYUDA!!!!!!!
    GRACIAS

  18. 19 Nico 10/20/2013 a las 14:16

    Nombre Tipo Datos
    (Predeterminado) REG_SZ (valor no establecido)
    Default REG-EXPAND_SZ %SystemDrive%Users/Default
    ProfilesDirectory REG-EXPAND_SZ %SystemDrive%Users
    ProgramData REG-EXPAND_SZ %SystemDrive%ProgramData
    Public REG-EXPAND_SZ %SystemDrive%Users%Public

  19. 20 Nico 10/20/2013 a las 15:08

    LO ARREGLE!!!!! GRACIAS POR LA AYUDA!!!!!!
    ME PASO EN EL WIN7!!!!!
    OTRA VEZ GRACIAS!!!!!

  20. 21 Yamila Farinelli 10/20/2013 a las 23:10

    Salvaste mi compu! millon de graciassss

  21. 22 Sonia 12/02/2013 a las 6:59

    Muchas gracias por tu publicación, ya pude solucionar mi problema!

    Saludos


Deja una respuesta

Introduce tus datos o haz clic en un icono para iniciar sesión:

Logo de WordPress.com

Estás comentando usando tu cuenta de WordPress.com. Cerrar sesión / Cambiar )

Imagen de Twitter

Estás comentando usando tu cuenta de Twitter. Cerrar sesión / Cambiar )

Foto de Facebook

Estás comentando usando tu cuenta de Facebook. Cerrar sesión / Cambiar )

Google+ photo

Estás comentando usando tu cuenta de Google+. Cerrar sesión / Cambiar )

Conectando a %s




Categorias

RSS YTuQueLeeS

  • Ha ocurrido un error; probablemente el feed está caído. Inténtalo de nuevo más tarde.

RSS ALT1040

  • Ha ocurrido un error; probablemente el feed está caído. Inténtalo de nuevo más tarde.

RSS Acceso Directo

  • Ha ocurrido un error; probablemente el feed está caído. Inténtalo de nuevo más tarde.

RSS Microsiervos

  • Boeing se plantea abandonar la producción de 747 07/28/2016
    En su más reciente informe para el equivalente estadounidense a la comisión del mercado de valores Boeing dice que está planteándose dejar la producción del Boeing 747. Aunque es probablemente el avión de pasajeros más conocido de la historia sus ventas en los últimos años no han dejado de bajar –conviene recordar que está en servicio desde 1970– y no por la […]

RSS Bitelia

  • Ha ocurrido un error; probablemente el feed está caído. Inténtalo de nuevo más tarde.

Seguir

Recibe cada nueva publicación en tu buzón de correo electrónico.

Únete a otros 354 seguidores

A %d blogueros les gusta esto: