Posts Tagged 'vmware'

Recuperar password en VMWare vCenter Server Appliance 6.5

Esta mañana he estado leyendo un interesantísimo artículo de Alex Samoylenko, CEO de Nova Games y escritor en el blog de StarWind, que creo que os puede ser de mucha mucha utilidad:

Recuperar el password en un vCenter Server Appliance

Si ya lo habéis instalado, veréis que este nuevo vCenter está basado en Photon (https://vmware.github.io/photon/) y para poder recuperar el password, nos explica:

¡Antes de nada hacer un Snapshot!

– Una vez que cargue el sistema operativo, pulsamos <e> para acceder al menú de edición de GRUB.

– Buscamos la sección done se inicia Linux (empieza con “linux”) i añadimos al final lo siguiente: rw init=/bin/bash

reset root password on vCenter Server Appliance

– Pulsamos F10 para continuar con la descarga

– Escribimos passwd en la línea de comandos y escribimos el password de root

– Desmontamos el sistema de ficheros con unmount /

– Reiniciamos el vCenter Server Appliance 6.5 con el comando reboot –f

– Hecho esto, el password del vCenter se reiniciarà. Una vez lo comprobéis que funciona todo, ¡recordad de eliminar el sanpshot!

Fuente | 3 useful tricks with VMware vCenter Server Appliance

Anuncios

VMWare: Unable to power on Virtual Machine

Buf…. maldito mensaje… y además ¡genérico! Bueno, en mi caso esta noche no podía arrancar una máquina virtual porqué me daba un error de un datastore que no estaba activo (lo peté del Datacore) pero aun estaba asociado a una máquina virtual.

El error que me daba era: Virtual disk ‘Hard disk 3’ is not accessible on the host: Unable to access file [VMFS Store Name] VM Name/VM Name.vmdk

Antes que nada, ¡calma! La solución es fácil y divertida de hacer Smile vamos a ello:

1) Primero lo que debemos hacer es (en caso de no tenerlo activado) arrancar el servicio SSH en el host donde tengamos la máquina virtual hospedada.

2) Editamos la máquina virtual y buscamos el disco vmdk que nos está dando problemas (y que muy probablemente no nos dejara remover así como así…) y vemos que en las propiedades el Virtual Device Node. Tomamos nota de él, en nuestro ejemplo SCSI (0:0) Hard disk 1

image

2) Nos conectamos mediante Putty al host y navegamos al siguiente directorio:

cd /vmfs/volumes/[Datastore donde está alojada la MV que no arranca]/[Nombre de la VM]

3) Una vez dentro, editamos el fichero vmx con el vi:

vi [Nombre de la VM].vmx

4) Vamos al final del fichero y buscamos las líneas que empiezan por el Virtual Device Node que nos hemos apuntado antes (en el ejemplo scsi 0:0) y las eliminamos. ¡Ojo! Solamente las que empiezan por scsi 0:0 o el valor que tengamos (suelen ser unas 4 o 5 líneas).

Nota: Para los que nos estáis familiarizados con el Putty, para editar el fichero pulsamos la tecla INSERT, eliminamos con SUPRIMIR y para guardar/salir pulsamos ESC y escribimos :wq!

5) Bien, cerramos el Putty y nos dirigimos a nuestro vCenter. Hacemos clic con el botón derecho sobre la máquina virtual que no arranca y le damos a Remove from Inventory. Esto lo hacemos ya que como hemos editado el fichero vmx, el host debe volver a leerlo.

6) Vamos al datastore donde tengamos la máquina virtual que no arrancaba, buscamos el fichero vmx y con el botón derecho seleccionamos Add to Inventory.

¡Y listo! Nuestra máquina virtual ya arranca pero esta vez sin el disco vmdk que nos daba problemas.

Error en la instalación de vSphere 6.0

Ya sé que hace mucho tiempo que no escribo nada interesante y me han llegado algún que otro mail, quejándose un poco de por qué tengo el Blog desactualizado. La verdad es que no dispongo de mucho tiempo y, cuando encuentro/soluciono alguna incidencia que quiero compartir con vosotros, pues me resulta imposible poderlo hacer. Así que, espere que (por enésima vez) pueda como mínimo escribir con cierta regularidad al respecto.

Dicho esto, os comento un reciente error (de hace algunos meses) que me daba la instalación del vSphere 6.0 como appliance. Los únicos vSphere que había instalado (en su versión 6.0) y por necesidades del guion, fueron sobre Windows Server 2012 R2 y la primera vez que lo instalé como appliance no paraba de darme errores en la instalación: Firstboot script execution error.

Pues bien, la solución la hallé aquí i la comparé en este blog, y la verdad la solución me dejó perplejo: solamente hay que añadir 1 solo registro DNS durante el proceso de instalación (a ser posible el del dominio) y si así persiste el error, añadir un registro DNS al controlador de dominio antes de la instalación (a mi me funcionó el primer paso).

Como comenta alguien en los foros de VMware…

vmware_please


Categorias

Enter your email address to follow this blog and receive notifications of new posts by email.

Únete a otros 386 seguidores

RSS Acceso Directo

  • Amazon se une a las plataformas online que transmiten la NFL 09/02/2017
    Esta por empezar una nueva temporada de Futbol Americano de la NFL y tendrás la oportunidad de verla donde más te guste o convenga, pues cada vez más cadenas o plataformas se suman a las transmisiones de este deporte que cada día es más popular a nivel mundial. Las cadenas …

RSS Microsiervos

  • Cosas extrañas… que suceden entre multiuniversos con partículas cuánticas entrelazadas 10/16/2017
    En este delicioso episodio de Sixty Symbols la astrofísica Becky Smethurst utiliza el alfabeto de luces de la pared de Stranger Things para elucubrar una teoría física alocada acerca de si podría ser posible transmitir mensajes entre dos universos mediante un mecanismo parecido, en este caso partículas entrelazadas. La teoría de Smethurst parte de las propie […]

RSS Bitelia

  • Los mejores plugins para gestionar, editar y buscar imágenes en WordPress 10/16/2017
    Encuentra las mejores fotografías, edítalas y crea galerías fácilmente. WordPress es uno de los gestores de contenido o CMS más populares, en parte gracias a sus más de 50.000 plugins, que añaden nuevas funciones, mejoran las ya existentes y, en definitiva, hacen más llevadera la tarea de publicar contenido en tu página personal o profesional. De plugins par […]